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Introduction 

The ErgoSoft RIP is build of several modules. The main module, the JobComposer is used to 
create, edit and print all your jobs. Even controlling the output process is possible within the 
JobComposer though the output process is handled in other modules. The JobComposer 
offers several functions to configure it according to your needs. Those can be separated into 
two main categories: 

 Function to configure the layout of the ErgoSoft RIP in order to adjust it to your preferred 
workflow. 

 Default settings concerning the behavior of the ErgoSoft RIP as well as default settings 
concerning image and job layout. 
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JobComposer Layout 

Introduction 

The JobComposer is the main module you are working in while creating, editing and printing 
your jobs. Depending from your workflow and the current task you are doing, different 
layouts might help in increasing the efficiency of your workflow. For example, when creating 
the job and placing the images within the job, you need to see much of the job but not all 
images in detail. But when editing an image, you might prefer seeing just one image but not 
the complete job. 

The following documentation will describe the functions available to help you customizing 
the JobComposer to your needs in the different stages of your workflow. 

The JobComposer is build using the following elements: 

Main job window 
The main job win-

dow is the heart of the 
JobComposer. Working 
without it is impossible. 

Windows 
Other windows 

holding information 
about the current job or 
image as well as windows 
for monitoring the 
workflow can be acti-
vated and deactivated. 

Toolbars 
Toolbars hold icons 

for often used functions. 
They can be activated 
and deactivated accord-
ing to your needs. 

Menu bar 

Status bar 

Rulers 
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Workspaces 

A workspace is defined to be the complete JobComposer layout that is built by the size and 
position of the visible toolbars as well as the size and position of the visible windows. There 
are three pre-defined workspaces: Standard, Edit, and Custom. 

The current workspace can be modified any time by activating and deactivating toolbars, 
activating and deactivating windows as well as positioning toolbars and windows. 

 
Saving a Custom Workspace 

 Configure the JobComposer layout according to your preferences. 
 Make sure that menu View > Workspaces > Enable Workspace Change is activated 

(checked) 
 Select menu View > Workspaces > Copy To 
 Select the workspace you want to modify or select New to save a new workspace 

 
Selecting a Workspace 

 To select one of the pre-defined workspaces press F2 for Standard workspace, F3 for Edit 
workspace and F4 for Custom workspace. 

 To select another workspace launch menu View > Workspaces and selected the desired 
workspace. 

 
Automatic Workspace Change 

The ErgoSoft RIP offers a useful function to easily switch between the Standard and the Edit 
workspace. 

 Set menu Tools > Options > Preferences > Application > User Interface Preferences, item 
Job Double Click Action to Toggle Workspaces 

 To switch to the Edit workspace: double-click on an image 
 To switch to the Standard workspace: double-click on an empty space in the job 
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Job Window 

The job window is the heart of the ErgoSoft RIP user interface. You open and design jobs in 
it. You are not limited to have just one job open at a time; there is almost no limit to the 
number of opened jobs. 
There are several functions available that will ease your workflow. 

 
Arranging Jobs 

By default, the jobs are displayed 
in tabbed order. To select a cer-

tain job, just click on it. 
 

When more than two jobs are 
open, right-clicking on the job 

window context menu (job name in the 
tab) will offer the possibility to split the 
job window vertically or horizontally to 
display 2 or more jobs at the same 
time. Please note that the jobs can be 
arranged only horizontally or vertically. 

To move a job to another tab group 
select the appropriate command from 
the job window context menu or simply 
drag it with the mouse into the desired 
tab group. 

To resize the visible part of the 
tab group, simply drag the sepa-

rator to the desired position. 

Images can simply be dragged from 
one job into another one when both 
jobs are visible. 
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Job Layout Helpers 

When the rulers are visible (menu View > Rulers), positioning guide lines can be created: 

Activate the guide lines by check-
ing menu Edit > Guide Lines. 

 
Creating a guide line 
Click with the mouse into the 

horizontal/vertical ruler and move the 
mouse with the left mouse button be-
ing pressed down/right into the de-
sired position in the job. 

To move a guide line 
Grab the guide line with the mouse 
and move it to another position. 

To remove a guide line 
Move the guide line out of the job 
window. 

When moving images with the mouse they will snap to the guide lines. 

 
 
Other Windows 

In addition to the job windows, the ErgoSoft RIP allows to display several other windows: 

 Properties: Displays properties and commands concerning the current job or image. 
 Image Preview: Displays a preview of the current image(s) in relation to the selected 

command in the Properties window. 
The following windows reflect the production state: 

 Preview: Connects to the JobQueueServer and displays a preview of the selected 
(printed) job. 

 Details: Connects to the JobQueueServer and displays information about the selected 
(printed) job. 

 Done: Connects to the JobQueueServer and displays the list of done jobs. 
 Waiting: Connects to the JobQueueServer and displays the list of jobs waiting for being 

processed. 
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Activating Windows 

Make sure that Enable Workspace Change is activated in menu View > Workspaces. 

Select menu View > Tools and check the desired window from the lower part of the list. 

 
 
Arranging Windows 

Make sure that Enable Workspace 
Change is activated in menu View > 
Workspaces. 

The windows can be positioned 
as window or docked to one side 

of the JobComposer window. 
To undock a window, double-click 

its title bar. 
To position a window, move it until 

positioning arrows (a) appear in the 
JobComposer window. Then, move it 
on the arrow pointing to the position 
at which it should be put. 

To position the window in tabbed 
group, drag it on the window title of 
the desired window group. 

To resize a window, move the window separator. 
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Default Settings 

Workspace 

Besides the possibility of creating and saving workspaces, which is described in the chapters 
above, menu Tools > Options > Preferences > Application > User Interface Preferences offers 
some settings controlling several actions when working in the job. 

Selection Context 
Menu 

This setting controls the im-
age context menu: 

 Standard (default): 
Shows just the commands 
that are not available in 
the image Properties win-
dow reducing the number 
of entries dramatically. 

 Select Property Page: 
Shows all image editing 
commands increasing the 
number of entries in the 
image context menu dra-
matically. 

 Legacy: 
Shows all image editing commands available but activates just the ones that have been 
available in version v.2008 of the ErgoSoft RIP. 

Automatic Apply Discard 
This setting specifies what will be done when you made changes to some settings in 

the Properties window and select another command or property without applying or discard-
ing the modifications. 

Job Double Click Action 
This setting specifies what will be done when you double-click an image or the job: 

 None (default): Nothing will happen 
 Toggle Workspace: Double-clicking an image will automatically switch to the Edit work-

space while double-clicking the job will switch to the Standard workspace allowing fast 
workspace change. 

Ask to Save Modified Job 
This setting specifies what will be done when you close a modified job. 
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Job 

Menu Tools > Options > Preferences > Job > Job Default Settings and menu Tools > Options > 
Preferences > Job > Extras offer some default settings for job layout as well as for processing 
jobs. 

Mark Ask on every new job 
when you want to specify the 

media size, margins and job processing 
policy settings for each new job. 

The functions for selecting a me-
dia size are described in the ma-

nual part about Print Environments. 
The global media size configuration 

is disabled when the media size confi-
guration is activated in the current print 
environment. 

The image margin configuration 
is described in the manual part 

about Print Environments. 
The global image margin configuration is disabled when the media size configuration is 

activated in the current print environment. 

Select the Job Processing Policy that is to be used as default for processing jobs. For a 
description of Job Processing Policies please refer to the manual part about Special 

Workflow Tools. 

The Outer Margin is added as 
white border outside of the print 

marks. Please note that the outer 
margin is always used and not only 
when the print marks are activated. 

Specify the method for centering 
images as well as an offset. When 

using media margins or ink control 
strips or plotter marks, the job size is 
smaller than the media size and the 
center of the job size may be different 
from the center of the media size, espe-
cially when the not available left and 
right media portions are different. 
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When importing an image that is wider than the job, the image is automatically tiled. 
Automatic tiling is also used when an image is scaled to a size wider than the job. 

This setting specifies how automatic (horizontal) tiling is done. Vertical tiling must always be 
done manually. Select whether all tiles will be of Equal Size or whether the first tiles will be of 
Maximum Size and the last one will be smaller. Specify the value of horizontal Overlap. 

The setting for Put each tile on a separate page is default for each time manual tiling is 
launched – even when the selected image is already tiled using the opposite setting from the 
one specified as global option. 

This setting allows configuring and activating the special identification lines for the Fo-
toba cutter. The Fotoba cutter needs special marks around the images themselves. 

Check Print Cut Marks and specify the size of the Fotoba strips. Please note that the print 
marks are switched off when using the Fotoba cutter. 

 
Image 

Menu Tools > Options > 
Preferences > Image allows 
specifying default settings 
for image format, print 
marks, image AddOns, im-
age margins, color man-
agement and PostScript/ 
PDF settings. 

You may select a custo-
mized preset or just enter 
the desired settings. 

For a detailed description of 
the available options please 
refer to the manual part 
about image preset (Image 
Editing Automation). 
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Access Levels 

Menu Tools > User Level offers 2 user levels: Administrator and Production. This command 
allows entering a password for the administrator so that the ErgoSoft RIP will automatically 
start in production mode in which e.g. modifying the print environments is not possible. 

Select the user mode in which you want to currently run 
the ErgoSoft RIP. In Administrator mode, click on 
Change to change or set a password for the administra-
tor mode. This password must be entered each time you 
want to run the ErgoSoft RIP in administrator mode. 
Production mode runs without a password. 

When a password has been set for administrator mode, the ErgoSoft RIP automatically 
starts in production mode and locks functions such as creating density linearizations and 
printer profiles as well as creating or modifying print environments. 

 
Others 

Display Configuration 

Menu Tools > Options > Preferences > Application > Display offers some options to configure 
the display as well as image viewing and editing. 

Select the monitor profile that 
you want to use for displaying 

images in the image editing functions. 
Clicking on Delete removes the 

selected monitor profile after 
confirmation from the hard disk. 

Clicking on Import helps in 
importing monitor profiles to the folder 
in which the ErgoSoft RIP expects 
them to be. 

Select the desired Unit of Meas-
ure (Centimeter, Inch, Millimeter, 

Point, or Pica). 

Enter the complete path name for the applications you want to use for Viewing or 
Editing raster images as well as the application you want to use for viewing and editing 

Vector files. 
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Enter separators that are used to split the alphabetical list of available print environ-
ments or cut environments for the tree structure.  

Please note that not allowed characters and signs are removed from the list without any no-
tice. Thus, after having entered the separators and closed the dialog box be sure to check the 
list again. 

 
Preview Management 

Menu Tools > Options > Preferences > Application > Snapshots offers some options for man-
aging the previews. 

Check Store all snap-
shots in a common 

local folder to save the 
snapshots in subfolder 
Files\SnapRO\... of the user 
data folder. Since the com-
plete path of the image 
folder is appended to the 
path of the user data folder 
you should take care that 
this path will not exceed the 
limits of your operating 
system by using a short 
user data folder path 
and/or short image folder 
paths. 

When Update automat-
ically is checked, a preview 
is created automatically 
whenever an image is imported for which no preview has yet been created. 

Enter the file size in KB that snapshots shall use in high resolution (display of images in the 
job). Snapshots for low resolution (display of snapshots in Album and preview in import di-
alog and information) are sized automatically at a ratio of the high resolution snapshots. 
When the resolution of the snapshot is not good enough for the selected zoom factor, the 
original image is automatically used for the display. 

Click on Delete All Snapshots to remove all snapshots from the hard disk. They are re-
created when needed. 

This dialog part allows controlling the storage space usage for snapshots for complete 
hard drives. To limit the used disk space select the hard drive, check Limit space con-

sumption and enter the amount in Mb that might be used for snapshots on this hard drive. 
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In addition to the global space limitation per hard drive, the snapshot management can 
be configured for each folder: select the folder, limit the storage space, and let all snap-

shots delete automatically that are not used for a certain time, or exclude the folder from the 
automatic snapshot removal process. 

Click Remove Folder to manually remove the selected image folder from the list. 

Specify whether you want to suppress the image display in the job completely and 
whether you want to use the original file instead of the extra created snapshots for the 

display in the job. 
Enter the cache size in MB that may be used for displaying snapshots in the job. Half of 

this value is used for displaying the snapshots in Album. 
Recommended size: 16-1024 MB, default: 80 MB 

 
Controlling PostScript Rasterization 

Since the settings for PostScript Rasterization are very complex they are described in the ma-
nual part about Controlling PostScript Rasterization. 
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Measuring Configuration 

Menu Tools > Options > Preferences > Application > Spectrophotometer offers some settings 
for defining the communication parameters between the ErgoSoft RIP and a spectrophoto-
meter. 

Select the type of 
your spectrophoto-

meter and click Detect to 
let the ErgoSoft RIP find 
the connection. Some spec-
trophotometers allow addi-
tional configurations or 
calibrations which are avail-
able by clicking on Options. 

For certain workflows 
it might be necessary 

not to use the default ICC 
standard based on D50 but 
a special measurement spe-
cification that is based on 
D65. 

Please note that this set-
ting must be done before 
the first measurement is started because the resulting Lab values depend on the selected 
measurement specification. Density linearizations and printer profiles created with D65 can 
only be used when the appropriate measurement specification is set. 

Select the Print Marks preset that is to be used when printing calibrations charts. The 
selected print marks settings for calibration charts may be different from the global 

print marks settings for images. 
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